I figrued out what was going wrong. After looking into the log file and finding that error message, I was able to deduce that I need to upade xlibs. Once this was done everything worked fine.

For anyone that runs into this issue run this command:
yum install libX11